Apresia13200-52GT 基本コマンド

ネットワーク

日立じゃなくなったりオリックスに買収されたりいろいろ忙しい Apresia さん。ググってもマニュアルがなかったので手探りで実施した時のメモ。

AEOS (APRESIA Extended Operating System) 8系。

最近エンタープライズ向けで主流の NP シリーズで採用されている AEOS-NP とはかなりコマンドが異なるためご注意くださいませ。マニュアルが非公開?のため、あくまで参考情報です。

試した環境 Apresia13200-52GT
System Revision : 8.17.04

初期ユーザ: adpro
初期パスワード:なし

ホスト名(以下ホスト名の表示は省略)

>en
# conf t
(config)# hostname APRESIA13200-52GT
APRESIA13200-52GT(config)#

デフォルトゲートウェイ

(config)# ip route 0.0.0.0 0.0.0.0 172.16.1.254

# show ip route
Codes: K - kernel route, C - connected, S - static
       * - candidate default

Gateway of last resort is 172.16.1.254 to network 0.0.0.0

S*      0.0.0.0/0 [1/0] via 172.16.1.254, manage
C       127.0.0.0/8 is directly connected, loopback
C       172.16.1.0/24 is directly connected, manage

ssh 設定(マネージメントポートを使用、鍵などの表示は一部省略)

(config)# interface manage 
(config-if-mng)# ip address 172.16.1.xx 255.255.255.0

# sshd keygen rsa 4096 
% Generating RSA key pair for version 2 protocol. Wait for a while.
% Done.

# conf t
(config)# username naoki adpro 

(config)# password naoki 
New password:
Retype new password:

(config)# sshd server 

# show sshd server
SSH server status
 IPv4 Status : ENABLE
 IPv6 Status : DISABLE
 Mode        : ALLOW

telnet無効化(デフォルト有効)

# show telnet server
Telnet server status
 IPv4 Status : ENABLE
 IPv6 Status : ENABLE
 Mode        : ALLOW

# conf t
(config)# telnet server disable
(config)# telnet ipv6 server disable
(config)# exi

# show telnet server
Telnet server status
 IPv4 Status : DISABLE
 IPv6 Status : DISABLE
 Mode        : ALLOW

VLAN設定

(config)# vlan database
(config-vlan)# vlan 10 name test
(config-vlan)# vlan 20 name naonet
(config-vlan)# exit
(config)# interface port 1/1
(config-if-port)# switchport mode access
(config-if-port)# switchport access vlan 10
(config)# interface port 1/2
(config-if-port)# switchport mode trunk
(config-if-port)# switchport trunk native 1
(config-if-port)# switchport trunk add 20


# show vlan

--- vlan port information ---
                  a = access-port  t = trunk-port
                  C Port
                    1      8 9     16 17    24 25    32 33    40 41    48 49
                    +------+ +------+ +------+ +------+ +------+ +------+ +---
 Port Mode        1 ataaaaaa aaaaaaaa aaaaaaaa aaaaaaaa aaaaaaaa aaaaaaaa aaaa

--- vlan mapping information ---
                  St = Status  En = Enable  Dis = Disable
                  u = untag  t = tag  p = protocol vlan
                  C Port
                    1      8 9     16 17    24 25    32 33    40 41    48 49
 Name     VID St    +------+ +------+ +------+ +------+ +------+ +------+ +---
default     1 En  1 .uuuuuuu uuuuuuuu uuuuuuuu uuuuuuuu uuuuuuuu uuuuuuuu uuuu
test       10 En  1 u....... ........ ........ ........ ........ ........ ....
naonet     20 En  1 .t...... ........ ........ ........ ........ ........ ....

--- protocol vlan information ---
 VID  protocol   type
---------------------

SNAP nonzero OUI: Disable

NTP設定

(config)# ntp enable
(config)# ntp server 172.16.1.254

# show ntp
 NTP Configurations
    NTP Server:   172.16.1.254
    Interval  :   36 (hour)
    Status    :   enable

 NTP Time Renewing Information
    Renewing time:   Mon Jul 19 22:37:12 2021
    Time offset  :   -21.827815 sec.
    Synch. server:   172.16.1.254
          stratum:   2

SNMP設定

(config)# snmp-server name apresia13200-52gt
(config)# snmp-server community rw communityname 172.16.1.1 255.255.255.0
(config)# snmp-server host communityname 172.16.1.1 version 2


# show snmp-server

SNMP management: Enabled

SNMP mib management:
 Read-Only manager:  Enabled
  IP address                                Community Name
                                            public

  IPv6 address                              Community Name
                                            public

 Read-Write manager: Enabled
  IP address                                Community Name
  172.16.1.1/24                            communityname

  IPv6 address                              Community Name
                                            private

SNMP trap management:
  authentication failure: Enabled
  cold start            : Enabled
  cpu utilization       : Enabled
  memory used notify    : Enabled
  system status         : Enabled
  topology change       : Enabled
  fan error             : Enabled
  login incorrect       : Enabled
  flooding control      : Enabled
  loop-watch            : Enabled
  mmrp                  : Disabled
  pbr                   : Enabled
  vb                    : Enabled
  link change mng port  : Enabled
  temperature condition : Enabled
  link change port 1/1  : Enabled   port 1/2  : Enabled
              port 1/3  : Enabled   port 1/4  : Enabled
              port 1/5  : Enabled   port 1/6  : Enabled
  ~~~中略~~~
  IP address                                Community Name       Trap Version
  172.16.1.1                                communityname        2


SysContact :
SysLocation:
SysName    : apresia13200-52gt

Trap Source: 172.16.1.1
Trap delay time: 1 seconds

RMON history default entry: Disabled

SYSLOG設定

(config)# logging ip 172.16.1.xx local7 info
(config)# logging source 172.16.1.52

設定保存

# write memory
Current running-config is saved to flash-config.
Writing to flash memory...
[OK]
Writing to SD memory...
ERROR: SD Memory card mount error

初期化

# erase staflash-config 
*# reboot 
save running config? (y/n): n
reboot system? (y/n): y
Jul 19 17:02:08  <system:emerg> Rebooting.

パスワードリセットする場合は login: で ap_recovery で入れるらしい。(未検証)

公式ページも消えていってるようなので、NPに集約されていくのでしょうか。。。

参考情報

Apresiaスイッチの基本設定・コマンドについて
2014年現在、ApresiaスイッチのOSとして、AEOS7とAEOS8がある。AEOS7の製品は主に、Apresia3400シリーズ、Apresia4300シリーズ、Apresia5400シリーズAEOS8の製品は主に、Apresia1
Network/Apresia - Memo
ディストリビューション層で使えてSDカードに設定をバックアップできるスイッチ「Apresia13200-48X-PSR」を手に入れたのでちょっと使ってみた
IT専門調査会社のIDC Japanによると、2018年の日本国内におけるネットワーク機器市場シェアはCiscoが47.9%、ヤマハが5.1%、アライドテレシスが5.0%となっており、事実上Cisco機器が業界標準となっています。しかし、状況によっては他ベンダーの機器のほうが都合がいい場合もありえます。RJ45とSFP...

コメント

タイトルとURLをコピーしました